Start a new topic

Transaction entry problem

 When entering transactions, the tab key allows moving from one field to another, and it is possible to enter direct, eg date, time, payee, value.

But the CATEGORY field, even when highlighted by TABbing from the previous field, requires a mouse movement to select the field, before starting to type.  

Now some people will use the mouse all the time, and use that to select from the list of categories, but I use keyboard shortcuts whenever possible.  Once I have used the mouse to click in the Category field, I then press a letter key, and use the arrow keys on the keyboard to select the required category.  I then press ENTER, to select it, and TAB on to the next fields.

Thanks for help on the above.   That made things much easier.  However, the 'space-bar' solution doesn't work completely on transfers.

Select a transfer transaction - check
Tab through to the 'To Account' box - check
Press Space Bar - check > pop-ups with accounts
Arrow-keys down to select account - check>
Press Enter key to select - #fail !

On Expense and Income transactions pressing the Enter key selects the category and puts that into the Category on the input window, but on Transfers it doesn't put the Account into the Account window - it's back to the blasted mouse again to do a click.
Remember, this is on a desktop iMac,, not a laptop with a trackpad close at hand.  It's inefficient, and frustrating cos I forget nearly every time!  
I enter a string of transactions, then a transfer and it works DIFFERENTLY!

Please fix this.


Hi Ian,

The problem is not MoneyWiz really, but how the how the keyboard settings are chosen in your System Preferences.

To overcome this issue, please open System Preferences on your Mac, go to Keyboard section. On top click on Shortcuts tab, and then at the bottom on "All Controls". After that TAB key will be able to focus not on just text fields, but also on Category field.


Thanks for a quick and comprehesive answer.  Unfortunately that is not the solution - or it is a solution to a different problem.  My settings were already as you suggested they be changed to (see image attached)

This does indeed allow the TAB key to move the cursor through all fields: however, I can type into all the fields, EXCEPT the category field.  Pressing ANY key (no, OK, I haven't tried them all, but I've tried all text keys), produces an error 'beep' and nothing happens.  When I click the mouse into the Category field the category list pops up and of course then typing any character (the cursor now being in the Category Search box) shortens the list of categories to those matching the characters.
~It would be better and easier if the Category field was in fact the search box - or pressing any key would produce the pop-up with that character key already in the search box.


Hi Ian,

Once you focused on Category field, you have to click a Space Bar key, so the list of categories will be open. The cursor will immediately get focused on Search field. After that you can either start typing the name of the Category in the search field, or your arrow keys to go through list of categories, and use Enter key to expand sub-categories and select needed categories.

I hope this helps.


You can select the accounts using using Space bar too. Even when selecting categories - it's just that Enter works there as well.

However, I do see the inconsistency you're reporting. Thank you for bringing this to our attention! I'll note it down to our team for further investigation!

Login or Signup to post a comment